Binary String Matching
Binary String Matching
时间限制:3000 ms | 内存限制:65535 KB
难度:3
- 描述
- Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
- 输入
- The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
- 输出
- For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
- 样例输入
-
123456731110011101101011100100100100011010110100010101011
- 样例输出
-
123303
string类的简单练习,find~~
[cpp]
#include “iostream”
#include “string”
using namespace std;
int main()
{
string s1,s2;int d,t;cin>>d;
while(d–)
{
t=0;cin>>s1;cin>>s2;
while(1)
{if(s2.find(s1)!=-1) {t++;s2[s2.find(s1)]=’2′;}
else break;}
cout<<t<<endl;
}
return 0;
}
[/cpp]