两点距离
两点距离
时间限制:3000 ms | 内存限制:65535 KB
难度:1
- 描述
-
输入两点坐标(X1,Y1),(X2,Y2)(0<=x1,x2,y1,y2<=1000),计算并输出两点间的距离。
- 输入
- 第一行输入一个整数n(0<n<=1000),表示有n组测试数据;
随后每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。 - 输出
- 对于每组输入数据,输出一行,结果保留两位小数。
- 样例输入
-
12320 0 0 10 1 1 0
- 样例输出
-
121.001.41
[cpp]
#include “iostream”
#include “stdio.h”
#include “iostream”
#include “math.h”
using namespace std;
int main()
{
int temp;
float x,y,x1,y1,x2,y2;
cin>>temp;
while(temp–)
{
cin>>x1>>y1>>x2>>y2;
x=x1>x2?x1-x2:x2-x1;
y=y1>y2?y1-y2:y2-y1;
printf(“%.2fn”,sqrt(x*x+y*y));
}
return 0;
}
[/cpp]