A problem is easy
A problem is easy
时间限制:1000 ms | 内存限制:65535 KB
难度:3
- 描述
- When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
- 输入
- The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
- 输出
- For each case, output the number of ways in one line
- 样例输入
-
123213
- 样例输出
-
1201
[cpp]
#include “iostream”
#include “math.h”
using namespace std;
int main()
{
int i,m,n,k,t;
cin>>n;
while(n–)
{
cin>>m;
t=sqrt(m+1);
for(i=2,k=0;i<=t;i++)
if((m+1)%i==0)
k++;
cout<