a letter and a number
a letter and a number
时间限制:3000 ms | 内存限制:65535 KB
难度:1
- 描述
- we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
- 输入
- On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
- 输出
- for each case, you should the result of y+f(x) on a line
- 样例输入
-
12345676R 1P 2G 3r 1p 2g 3
- 样例输出
-
123456191810-17-14-4
[cpp]
#include “iostream”
using namespace std;
int main()
{
char tc;
int temp,ti;
cin>>temp;
while(temp–)
{
cin>>tc>>ti;
if(tc>=’a’&&tc<='z') cout<<-(tc-96)+ti<