小学生算术
小学生算术
时间限制:3000 ms | 内存限制:65535 KB
难度:1
- 描述
- 很多小学生在学习加法时,发现“进位”特别容易出错。你的任务是计算两个三位数在相加时需要多少次进位。你编制的程序应当可以连续处理多组数据,直到读到两个0(这是输入结束标记)。
- 输入
- 输入两个正整数m,n.(m,n,都是三位数)
- 输出
- 输出m,n,相加时需要进位多少次。
- 样例输入
-
1234123 456555 555123 5940 0
- 样例输出
-
123031
[cpp]
#include “iostream”
using namespace std;
int main()
{
int m,n,t1,t2,temp;
while(1)
{
t1=t2=0;
temp=0;
cin>>m>>n;
if(m==0&&n==0) break;
if(m%10+n%10>=10) {t1++;temp++;}
if(m/10%10+n/10%10+t1>=10) {t2++;temp++;}
if(m/100+n/100+t2>=10) temp++;
cout<
2 Replies to “小学生算术”
你这样不是输入一行,按回车键就输出一行吗?
是的呢!